Supported browsers

Use Float on different browsers

Justyna Kawalec avatar
Written by Justyna Kawalec
Updated over a week ago

Float is best optimized for the latest versions of the following web browsers. Using earlier versions of the supported browsers may result in limited functionality. To ensure that you are using the newest version, visit the respective website of your browser:

Some browser extensions and translation tools may not be compatible with Float. If you come across an issue using one of these tools with Float, we'd recommend disabling the extension or translation tool in your browser.

📝Note: Internet Explorer is no longer supported. Due to security vulnerabilities, we stopped supporting it as of September 1, 2019. For a secure and optimized experience, we recommend switching to one of the supported browsers.

Did this answer your question?