Float runs best on the latest versions of Chrome, Edge, Firefox, Opera, and Safari. Earlier versions will be limited in functionality and in some cases, the site may not function at all when using an outdated browser.

You can check if you're running the most recent version by visiting your browser's website: 

Edge
Chrome
Firefox

Opera
Safari

Note: Due to security vulnerabilities, we stopped supporting Internet Explorer as of September 1, 2019.

Did this answer your question?